Compiler and Tool Help

Bloodshed

Bloodshed is a free IDE for C++ programming on Windows. Dowload the compiler from http://www.bloodshed.net/dev/devcpp.html.

Download the CCC library from http://horstmann.com/bigcpp and unzip in a location of your choice (such as c:\yourname\bigcpp).

Compiling a simple program from the book

  1. Start the Bloodshed IDE.
  2. Select Project -> New.
    ???
  3. Select Console Application
  4. Remove the useless main.cpp that Bloodshed provides: In the Project window, click on the [+] icon, then right-click on main.cpp.
    ???
  5. Select Project -> Add to Project, and add the file that you want to compile. Repeat if you want to include additional files (such as ccc_empl.cpp, ccc_time.cpp, or the files required for graphics programs).
    ???
  6. Select Execute -> Compile & Run
    ???

Compiling programs that use the Employee and Time classes

Follow the steps for simple programs.

Pay attention to step 5. In addition to the file that you want to compile, add the files c:\yourname\bigcpp\cccfiles\ccc_empl.cpp or c:\yourname\bigcpp\cccfiles\ccc_time.cpp to the project. (Change c:\yourname\bigcpp to the directory into which you unzipped the file with the book code.)

Compiling graphics programs

Follow the steps for simple programs.

In step 3, select "Windows application".

Pay attention to step 5. In addition to the file that you want to compile, add the files c:\yourname\bigcpp\cccfiles\ccc_msw.cpp and c:\yourname\bigcpp\cccfiles\ccc_shap.cpp to the project. (Change c:\yourname\bigcpp to the directory into which you unzipped the file with the book code.)

Before proceeding to step 6, go to Project->Project Options->Directories->Include Directories. Add c:\yourname\bigcpp\cccfiles to the (initially empty) list of directories. Be careful to click on the Add button. If you simply click Ok without first clicking Add, your selection is not added.
???